My handheld soft resets or reboots whenever I open the Documents application, or a file within the application.
| Document ID: 13568 |
<< Back
|
| Last Reviewed: 5/29/2009
This document applies to:
Documents To Go Premium Mac 11.0
Documents To Go Premium Win 11.0
Documents To Go Standard Win 11.0
Documents To Go Premium Mac 10.0
Documents To Go Premium Win 10.0
Documents To Go Professional Mac 10.0
Documents To Go Professional Win 10.0
Documents To Go Standard Mac 10.0
Documents To Go Standard Win 10.0
Documents To Go Premium Mac 9.0
Documents To Go Premium Win 9.0
Documents To Go Standard Mac 9.0
Documents To Go Standard Win 9.0
Documents To Go Premium Mac 8.0
Documents To Go Premium Win 8.0
Documents To Go Professional Mac 8.0
Documents To Go Professional Win 8.0
Documents To Go Standard Mac 8.0
Documents To Go Standard Win 8.0
Documents To Go Premium Mac 7.0
Documents To Go Premium Win 7.0
Documents To Go Professional Mac 7.0
Documents To Go Professional Win 7.0
Documents To Go Standard Mac 7.0
Documents To Go Standard Win 7.0
|
|
|
|
Problem:
My handheld soft resets or reboots whenever I open the Documents application, or a file within the application.
Cause:
There are different reasons why this problem may be happening. Most of the time, it is the result of a corrupt Documents To Go preference file or database file on the handheld. The way to fix this is often to delete the corrupt preference or database file from the handheld. It may also be necessary to uninstall and reinstall Documents To Go on the handheld.
Even if you have already tried to solve this problem by uninstalling and reinstalling the Documents To Go handheld applications, you should still follow all the steps in Solution #1 and Solution #2 first. If these steps do not fix the problem, follow the steps in Solution #3.
Solution #1:
- Download the latest version of the DataViz Tech Tool (click the link and save it to the Desktop)
- Double-click the dataviztech.prc file to add it to Quick Install (or Install Tool)
- Close Quick Install (or Install Tool) and HotSync your handheld
- After the sync, open the DatavizTech application on the handheld
- Tap the upper left corner of the screen (or press the Menu button) to view the menu bar
- Select Advanced Options
- Tap the first button, "Delete Preferences" (tap Yes to confirm)
- Next, tap the third button,"Delete Temp Database" (tap Yes to confirm)
- Soft-reset by pressing the reset button inside the hole on the back/bottom of the handheld (on some Treo models, you may need to remove the battery)
- After the soft reset, try Documents To Go on the handheld to see if it works
Solution #2:
If Solution #1 does not solve the problem, try uninstalling Documents To Go from the handheld:
- Open the "DataVizTech" application on your handheld
- Tap the button for "Uninstall Documents To Go" (tap Yes to confirm)
- Tap the upper left corner of the screen (or press the Menu button) to view the menu bar
- Select Advanced Options
- Tap the first button, "Delete Preferences" (tap Yes to confirm)
- Next, tap the third button,"Delete Temp Database" (tap Yes to confirm)
- Soft-reset by pressing the reset button inside the hole on the back/bottom of the handheld (on some Treo models, you may need to remove the battery)
Once the handheld is ready, you can reinstall the Documents To Go handheld applications:
- Open Documents To Go on the desktop computer
- Click on the Tools menu (or Documents To Go menu on a Mac) and select Re-Install Handheld Applications
- On the screen that appears, make sure your Palm username is selected, and click OK
- Read the message that appears and click OK
- Click on the Tools menu (or Documents To Go menu on a Mac) and select Preferences
- Click on the "HotSync Action" tab, and select "Desktop Overwrites Handheld"
- Click OK, then close Documents To Go
- Hotsync the handheld
- After the HotSync, open Documents To Go on the handheld to see if it works
Solution #3:
If Solutions #1 and #2 do not solve the problem, this issue is probably the result of a corrupt Palm preferences database on the handheld. This Palm preference file is used by various applications, including Documents To Go. There are various reasons that file may become corrupt. If the problem started after restoring backup files to a new Palm handheld, it could have happened because of an older preference file or application that is incompatible with the new model. However, there are many other reasons why it may become corrupted, and the steps below will help create a new Palm preference file, regardless of how it became corrupt in the first place.
NOTE: For more information about avoiding problems that can happen when upgrading to a new Palm OS handheld, click here for Palm's online upgrade guide.
Follow all the steps below to remove the corrupted Palm preference file and create a new one:
-
HotSync your handheld to make sure your data is fully backed up on the computer. To make sure your conduits are set correctly, Palm has steps to check conduit settings here: Changing conduit settings in the HotSync Manager
-
Hard reset your handheld. Palm has steps to do a hard reset here: How To Hard Reset
-
Delete a file named Saved_Preferences.PRC from your computer. That file can be found in the Backup folder for your handheld, which can usually be found in the following location:
Windows: C:\Program Files\Palm\"Palm username"\Backup
Mac: ~/Documents/Palm/Users/"Palm username"/Backups
Inside the Backup folder, find the Saved_Preferences.PRC file and delete it (or move it to the Desktop). If you have trouble finding your "Palm username" folder, Palm has steps to find it here: Find your device's User Folder on your desktop computer.
-
HotSync your handheld, making sure to choose the correct Palm username when prompted. During this HotSync, all the backup files (except Saved_Preferences.PRC) will be restored to the handheld.
-
After the HotSync is complete, open Documents To Go on the handheld to see if the problem still happens.
If you need to reinstall Documents To Go on your computer at any point, you can redownload the installer from the DataViz Download Site.
NOTE: The above steps are from Palm Inc's Knowledge Base, regarding a similar issue with Saved_Preferences.PRC. A link to this Solution ID can be found here:
How do I avoid the error 'Fatal Error Preferences.c line {number}, Pref.DB open error'?