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I am unable to open email attachments in Documents To Go on my BlackBerry.

Document ID: 14186 << Back
Last Reviewed: 6/23/2009

This document applies to:
Documents To Go Premium 2.0 for BlackBerry
Documents To Go Standard 2.0 for BlackBerry
Documents To Go Premium 1.0 for BlackBerry (OS 4.5/4.6)
Documents To Go Premium 1.0 for BlackBerry (OS 4.7 and above)
Documents To Go Standard 1.0 for BlackBerry (OS 4.5/4.6)
Documents To Go Standard 1.0 for BlackBerry (OS 4.7 and above)

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Problem:

I am unable to open email attachments in Documents To Go on my BlackBerry.

Cause:

Most email attachment problems on BlackBerry devices are related to the email service & software, such as BlackBerry Internet Service (BIS), BlackBerry Enterprise Server (BES), the email application, and so on. To open an attachment in Documents To Go, you must first be able to download the native file to the BlackBerry. Documents To Go has nothing to do with the ability to download attachments, as that is a function of the email application, the BlackBerry OS, and the server. You should be able to download native attachments regardless of whether or not Documents To Go is installed.

Before continuing, check the basics by answering these 3 questions:

  1. Are your email attachments supported by Documents To Go? CLICK HERE for more information.

  2. Can you download and save native email attachments? CLICK HERE for more information.

  3. Do the Documents To Go applications work on their own? Find and open the Documents To Go applications. Try to open a file saved to the Device Memory or Media Card. If using the Premium Edition, try to create a new file. If it works, the attachment problem has nothing to do with Documents To Go.

If the answer to all three questions is 'Yes', continue reading below for solutions to some common email attachment issues. NOTE: These solutions are for troubleshooting the BlackBerry software or email service, so if you need help with the steps or if they do not solve the problem, you will need to contact RIM/BlackBerry technical support for further help.

Solution:

When you select an attachment in an email on your BlackBerry, you should normally have the following options:

- An "Open Attachment" menu option: - A "Download Attachment" menu option: - An "Edit with Documents To Go" option (after selecting "Open Attachment"):

If you are missing any of these options, there is a problem and you will not be able to open the attachment in Documents To Go. Please select the symptom which best describes the problem you are having, and follow the steps to fix it:

The "Open Attachment" and "Download Attachment" menu options are missing.

Only the "Download Attachment" menu option is missing.

There is no option to "Edit with Documents To Go" when opening an attachment.


The "Open Attachment" and "Download Attachment" menu options are missing.

If you are using BlackBerry Internet Service (BIS):

This indicates that the BlackBerry Attachment Service is not installed on the BlackBerry device. To verify if the BlackBerry Attachment Service is installed on the BlackBerry device, perform the following steps:

  1. From the Home screen of the BlackBerry device, click Options.
  2. Click Applications or Advanced Options, then Applications.
  3. If BlackBerry Attachment Service is not listed, it is not installed.

Perform the following steps to install the BlackBerry Attachment Service:

  1. Connect the BlackBerry device to the computer.
  2. In BlackBerry Desktop Manager, double-click Application Loader. The Application Loader Wizard is prompted.
  3. Click Next.
  4. If prompted for a password, type the password.
  5. On the Device Application Selection screen, make sure the BlackBerry Attachment Service option is selected.
  6. Click Next.
  7. Click Finish.

NOTE: The above steps are from the BlackBerry support site. If you need help with these steps or if they do not solve the problem, you will need to contact RIM/BlackBerry technical support for further help.

If you are using BlackBerry Desktop Redirector:

The BlackBerry Desktop Redirector does not have attachment support at all. Therefore, email attachments sent through the redirector cannot be opened in either Documents To Go or the built-in viewers on the device. More information can be found on the following page of the RIM/BlackBerry support site:

The BlackBerry smarphone is configured to use BlackBerry Desktop Redirector.


Only the "Download Attachment" menu option is missing.

If you are using BlackBerry Internet Service (BIS):

There is a problem with the way your BlackBerry is interacting with the BlackBerry Internet Service (BIS). To fix this, you will need to "send service books" (which is used to fix various email issues on a BlackBerry). Follow the steps on the BlackBerry support site here:

How to send service books from the BlackBerry smartphone for BlackBerry Internet Service

NOTE: The above link will take you to the BlackBerry support site. If you need help with the steps there, or if they do not solve the problem, you will need to contact RIM/BlackBerry technical support for further help.

If you are using BlackBerry Enterprise Server (BES):

Check with your wireless carrier or IT department to determine the version of the BlackBerry Enterprise Server (BES) being used. RIM added the ability to download native email attachments to version 4.1.5 of the BES. Therefore, if you are using BES version 4.1.4 or lower, you will not be able to download native attachments to your BlackBerry, which means you will not be able to open them in Documents To Go. Click here to see the requirements for downloading native email attachments on a BlackBerry.


There is no option to "Edit with Documents To Go" when opening an attachment.

If you can download attachments and save them to your BlackBerry, but trying to open a supported email attachment automatically launches a built-in viewer or gives an error message, it is often due to one of the following reasons:

  • Your version of BES/BIS does not support downloading native attachments

    In order to download native email attachments to the BlackBerry and open them in Documents To Go, you must be using one of the following:

    • BlackBerry Enterprise Server (BES) - version 4.1.5 or higher
    • BlackBerry Internet Service (BIS) - version 2.5 or higher

    If you are using BIS, you should already be using version 2.5 or higher because Research In Motion (RIM) runs the service and has updated it.

    If you are using BES, check with your wireless carrier or IT department to determine the version being used. If you are not using BES version 4.1.5 or higher, you will not be able to download native attachments to your BlackBerry, which means you will not be able to open them in Documents To Go. Click here to see the requirements for downloading native email attachments on a BlackBerry.

  • You are using BlackBerry Professional Software

    BlackBerry Professional Software is very similar to BlackBerry Enterprise Server (but with a limit on some functionality). However, BlackBerry Professional Software does not currently support downloading native attachments. The ability to download native attachments will require an update from RIM. More information about BlackBerry Professional Software can be found here:

    BlackBerry Professional Software

 

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